5

I see my normal custom avatar up in the top bar and on my profile, but when I edit or answer a question, some horrid little blue square with white dots around the edges appears next to my attribution-box now.

I'm pretty sure that this behaviour is quite new (as in the last day or two; I just noticed it this morning, and thought I'd give it a little time in case it "self-corrected"), not related to the Users' Lost Avatars question from last fall.

What happened to my black-eyed photo? Where did I go? Will I ever come back, or am I trapped behind a blue box forever?

  • This same thing happened to me once yesterday, but I'm happy to report that my orange is back. Hopefully this is just some glitch that will indeed be self-correcting. – J.R. Feb 23 '17 at 23:21
  • Your question's user card shows your happy face for me. Does it not for you? If so, the first thing to try is to clear your browser cache. – Andrew Leach Feb 23 '17 at 23:50
  • @AndrewLeach I look like myself at home, but not at work. I shall have to try the cache-clearing first thing tomorrow, – Hellion Feb 24 '17 at 1:51
  • Hmm. I saw your normal avatar from my phone earlier today, but now that I look at this question from my computer I see the blue square with white dots. That's odd! – sumelic Feb 24 '17 at 4:50
  • 1
    Blue box, hmm? If you go back in time just a little, there was a spate of similar problems. Mine changes from time to time as well. One suggestion was to upload a custom version, but you've obviously already done that, and it hasn't prevented the issue. – Lawrence Feb 24 '17 at 9:04
  • Cleared my cache and I'm still seeing the horrid little blue box. Feh, – Hellion Feb 24 '17 at 15:57
8

Your image's address is https://www.gravatar.com/avatar/08e5993e7842278d5a35f526c6a285e2?s=32&d=identicon&r=PG, so your image was uploaded via Gravatar. The problem is not new; it started months ago (6 to be exact) and has gradually been affecting more and more users. Gravatar is having issues, so everyone with an image through them should switch (including those with an Identicon).

You should upload your image again through Imgur so it ends up on i.stack.imgur.com, which is guaranteed not to change or die.

I had this problem too (see here), and that was how I solved it. If you check, you'll see my image's address is https://i.stack.imgur.com/D2CgS.png.

  • I've had problems before with Gravatar images with ratings that were other than G. Might be related to that too. – Kit Z. Fox Feb 24 '17 at 18:07
  • Hmm. I doubt @Hellion's face is R-rated, but I suppose you never know how these things are assessed. – Andrew Leach Feb 25 '17 at 18:36
  • @KitZ.Fox How do you change the rating? Mine's just a picture of one letter, and it still changes to some generic icon occasionally. – Lawrence Feb 27 '17 at 12:12
  • @AndrewLeach it says it's rated PG in the link. – Kit Z. Fox Feb 27 '17 at 12:12
  • @Lawrence I can't remember. – Kit Z. Fox Feb 27 '17 at 12:14
  • @KitZ.Fox Ok. – Lawrence Feb 27 '17 at 12:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .