Recently, I cannot access the chat room. I only get this forever message ( I have left it for up to 24 hours and it still hangs) :

enter image description here

This started after the last updates around 4-5 months ago. Possibly it is my browser, but I kinda doubt it.

This is similar to this post: Chat hangs while loading. but even Jeff Atwood could not answer it to my satisfaction.

I use Firefox...this should not be an issue. "Clearing the browser cache" is not clear for the casual user.

I would appreciate some helpful advice.

  • Is your browser up-to-date? Does your computer have plenty of RAM? Is your broadband fibre? I don't know, I'm not a developer but I would check these things out if after a month, chat was still slow to load.
    – Mari-Lou A
    Dec 29, 2020 at 20:42
  • 2
    @Mari-LouA The last time you asked me all that was on another question about Ngrams , and I can assure you that all my software and hardware is totally up-to-date. I am a bit of a fanatic about updates, and my local broadband is possibly more advanced then what you enjoy. Dec 29, 2020 at 20:44
  • I also asked about RAM, fibre broadband... let's add routers for good measure, and whether you experience this sluggish behaviour only with chat. Then I'd wait until a community manager or a tech person responds. Check out Meta.SE to see if anyone else has (had) the same problem
    – Mari-Lou A
    Dec 29, 2020 at 20:49
  • 1
  • I will look into that @Mari-LouA Thank You. In the mean-time, I think other users could respond. Dec 29, 2020 at 21:03
  • 1
    @Mari-LouA that was a one-off event and was fixed in under 12 hours after it started. That isn't related to this issue when it both precedes that, and is still present.
    – Zoe
    Dec 29, 2020 at 21:12
  • @Zoe Can we resolve this here, or do I need to re-cross the post to SO? Dec 29, 2020 at 22:25
  • 1
    This has no business on SO -- general computing is off-topic. If you meant MSO, that's a different story, but this feels better suited on MSE. Here is fine too, though. SE presumably monitors the bug tag throughout the network, so here should be fine. Gets more eyes on MSE, however.
    – Zoe
    Dec 29, 2020 at 23:19

1 Answer 1


The browser cache should usually be suspected in cases like this. Of course, if you're used to programming your own router and everything, you probably don't need the level of detail here, but it may help someone else...

If you have another browser installed, you can attempt to get to the chat room with that (you don't have to be signed in on that browser; the chat room will load whether you're signed in or not). That won't do anything with your normal browser, but will at least confirm whether you can access the room from your computer at your location.

If that's OK, then you can do things with your browser's cache. The cache is a storage area where the browser stores static files like images and JavaScript scripts, because it's faster getting them from that local storage than it would be to fetch them over the internet each time they're needed. However, if the local copy gets corrupted, strange things can happen: the browser doesn't know something's gone wrong; it simply carries on using the local copy because it's there.

In many browsers, including Firefox, clearing the cache clears everything which has been downloaded from any site. You may not want to do that. However, you can at least check whether the cache is involved without clearing it completely.

What follows works for Firefox, Chrome and Edge; it may also be the same for Safari and other Webkit or Chromium-based browsers.

  • Go to the chat room: you'll get the message and not much else. Then use key combination Ctrl+Shift+I (that's I) to open the Inspector. Click Network (this image is from Firefox):

    Inspector's Network tab

    and then over to the right, check the Disable cache checkbox:

    Inspector's Disable cache checkbox

    Then reload the page. This forces everything in the page to be reloaded from the internet, without touching the local cached copy.

    If that works, you may find it's fixed it permanently — even though you disabled the cache, the browser may well have replaced what was there with what it's just downloaded. Uncheck Disable cache and try again.

    If all is well, you've fixed it. You can close the Inspector using the × just above the cogwheel (see the second image above).

  • If checking that checkbox made no difference, it's not the browser cache and you can stop reading here: you'll need to try something else. Make sure the checkbox is unchecked, and close the Inspector.

  • If checking the checkbox worked, but reloading with it unchecked didn't work, then you will need to clear the browser cache.

    Close the Inspector with the × button, and then from the "hamburger" menu in the top-right corner of the screen, choose Options. It has a cog-wheel icon.

    Hamburger menu

    In the menu on the left, click Privacy & Security, then scroll down the right-hand page to Cookies and Site Data. Click the screen button Manage Data....

    This will show a list of websites/domains for which Firefox holds data. Find stackexchange.com (you can use the search box), highlight that line and click the screen button Remove selected. Click the screen button Save changes and then Remove. Caution: This will also remove your login cookies on every SE site. You will be logged out.

    However, this "nuclear option" will completely reset everything your browser knows about Stack Exchange sites. While you will need to log in again, all pages, scripts and images will have to be fetched shiny and fresh and should no longer be corrupted.

  • I will certainly read this very carefully. Thank you for the time you have taken to prepare such a detailed response. Dec 29, 2020 at 21:15
  • I have the same problem with ELU chat. TGO chat loads instantly.
    – ab2
    Dec 30, 2020 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .