3

Since the first moment I looked to questions on EL&U this morning, I noticed something was wrong. This is a screenshot for a random question on the main site.

screenshot

As you see, the page doesn't show the badges in the top part; there are just the counters for the badges. The page doesn't show the voting arrows, the widget to add a question as favourite, and the Super drop-down menu (a.k.a. "the Collider").

I have this issue just on EL&U, and only on the main site. I don't have the same issue on the meta site, or other Stack Exchange site. This is what I see in this very site.

screenshot

I am using Safari 6.0 running on a Mac with OS X 10.8. I don't think that makes any difference, as the problem is just for EL&U, and its main site. I would think the problem is with the CDN, but I would expect to hit the same CDN when I visit any of the Stack Exchange sites. I thought to the server cache, but also in this case I imagine the problem would be visible in all the Stack Exchange sites.

  • Are you using Internet Explorer? – Andrew Leach Aug 6 '12 at 10:56
  • 2
    Yikes! No! I am not using Internet Explorer because there isn't Internet Explorer for Mac. :) – kiamlaluno Aug 6 '12 at 10:58
6

All the images are contained in one large composite, so if that is corrupt, all images will be affected. Each composite image is site-specific (so the arrows/badges can differ from site to site), so a corrupt image file will only affect one site.

Remove a corrupt image from the browser cache by either force-refreshing the page or actually clearing the cache.

Internet Explorer in particular has a very aggressive caching policy and will happily cache a corrupt image file. Other browsers may still do so (Older versions of Firefox in particular have been known to get really confused and retrieve entirely the wrong image from the cache).

This is the composite from Stack Overflow. You can see that each arrow, badge and the like appears and is simply sliced out of the image for display. If the image is corrupted, every graphical element will be affected.

Stack Overflow sprite image

  • That is. It was merely Safari that caught a corrupted file, for who knows which reason. Thank you. – kiamlaluno Aug 6 '12 at 11:32
  • Andrew, then I have encountered some other problem of which I'm not aware. Thank you. – user19148 May 4 '13 at 9:00
  • For an ELU page, what's the URL of the composite image? – James Waldby - jwpat7 Aug 16 '13 at 20:02
  • ELU composite image is at cdn.sstatic.net/english/img/sprites.png?v=2 – Andrew Leach Aug 17 '13 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .